Basic switch configuration
Command | Purpose |
service password-encryption | Enables password encryption |
hostname [Switch-Name] | Configure your switch's name |
enable secret [Some-Password] | Set the enable secret |
aaa new-model | enables aaa authentication model |
aaa authentication login default local | Sets authentication mode |
aaa authorization exec default local | |
ip http server | Enables web server |
ip http authentication local | Configures the web server to use the local authentication database |
line con 0 | Configures the Console for local database authentication |
login authentication default | |
logging synchronous | Ensures that console messages don't overwrite your commands |
line vty 0 15 | Configures the inbound Telnet lines for local database authentication |
login authentication default | |
logging synchronous | Ensures that console messages don't overwrite your commands |
ip domain-name [Domain-name] | Set the switch's domain name |
ip domain-lookup | Turn on switch DNS Resolution |
ip name-server [Resolver1] [Resolver2] | Enter primary and secondary DNS servers (secondary is optional) |
clock timezone [Timezone] [Hours-from-UTC] | Configure your timezone |
ntp server [NTP-Server-IP] | Configures your switch to get its time from your NTP server |
service timestamps log datetime localtime show-timezone | Configures your switch log to timestamp entries |
username [Your-username] privilege 15 password [Your-password] | Sets username and password. Used for web and CLI access |
ip default-gateway [Gateway-1] | Creates a default gateway for VLAN1 (switch administration) |
interface Vlan1 | Enter Vlan1 Configuration mode |
ip address [IP-VLAN-1] [Subnet-mask-1] | Configure the IP and Subnet mask for Switch management |
no shut | Turn on Vlan1 interface |
int range FastEthernet0/1 - [Number-of-switchports] | Enter FastEthernet configuration mode for all ports on switch |
switchport mode access | Enables these ports to be access ports for LAN devices |
no shut | Enables ports |
exit | Exits Interface configuration mode |
exit | Exits Global configuration mode |
wr | Copies running-config to startup-config |
Source: Techrepublic.com